Before getting started ...

First, a little note for a better understanding : Saturnin was the name of a little duck who was the hero of kiddie TV show on french TV in the late sixties. I think it'll explain a lot of things :) And no, I wasn't born at this time :P


Introduction

Saturnin 0.30
Copyright © December 2004. Runik
email : Runik
home page : Saturnin

What it's made of :

- Visual C++ 7.10
- Assembly for some opcodes
- OpenGL for display
- Lex/Flex for Saturn binary file disassembly
- Aspi layer for cd-rom data read

What it can do now :

- Saturn mode : some games are playable, some others show stuff and some just crash the emu
- STV mode : same as above.
- Possibility to load a Saturn binary file (like demos etc ...)
- Possibility to choose the language from a str file (which are just plain files).
- Possibility to debug the saturn (sh2, memory, etc ... useful for developpers)

What it can't do :

Read a game directly from an ISO file, coffee, play darts, etc ... (You'll be surprised to see how many things Saturnin can't do :P)

Its growth :

Master SH2 : 100%
Slave SH2 : 100%
Master/Slave communication : 50%
SMPC : 80%
Sound : 20%
VDP1 : 85%
VDP2 : 70%
SCU : 80%
DSP : 0%
CD : 65%
DMA : 95%
Interrupts : 100%

There are 2 versions of Saturnin :
- Saturnin SDE.exe : without debugger, faster but sometimes less compatible.
- Saturnin.exe : with debugger, slower but you can change the state of the emulator.

Some more things :
- Saturnin is slow : almost nothing is optimized for now. I focus on compatibility first
- There's no sound : I did some work on it, but not enough to hear something
- The debugger version generates huge amounts of log files
- Some Saturn games (like GT24) might lead to a cd-rom lock (ending by a reboot), so be warned


How it works

What it needs to run

Be sure to configure the paths (options->path)
Choose the mode (options->mode)

Controls are : (Emulator => Saturn/ST-V)
- arrow keys
- S => A
- D => B
- F => C or jamma 1
- X => X or jamma 2
- C => Y or jamma 3
- V => Z or jamma 4
- Return => Start
- F1 => Test switch
- F2 => Service switch
- F3 => Coin player 1
- F4 => Start player 1
- F8 => Bypass ST-V bios
- F9 => Reloads the texture cache (when colors seem wrong on screen)


Caution !!!

A few games could behave strangely, they might crash the emulator, lock the cd drive etc ...
Here is a little list of games with problems that I encountered during testing (I tested more than 450 games)

Saturn

GT 24
Hercs Adventure
Langrisser V
Lunar Silver Star Story
Noel 3
Panzer Dragoon Saga
Pulirula - Arcade Gears
Psychic Killer Taromaru
Samurai Shodown RPG
Shinobi Legions
Tactics Formula
Twinkle Star Sprites

ST-V

Dynamite Deka
Pro Mahjong Kiwame S
Sando-R
Suikoenbu
Virtua Fighter Kids

As I didn't test every game available for the system, there might be more ...


Thanks to ...

It's godfathers :

- Ben-J, webmaster of Consollection, who created the website and is hosting it. He's often feeding it.
- Fabien Autrel, the Satourne coder, who healed its malformations and fractures, where many others would have ended its life :)

Thanks to

- TyRaNiD
- Charles MacDonald
- Stefano Thieso
- Bart Trzynadlowski for letting me use his Turbo68K
- Stephane Dallongeville for his scsp core
- Mariusz Wojcieszek and Haze from Mame
- the Segadev list
- the Dynarec list
- SegaXtreme, NGEmu and EmuFanatics communities
- the Tradu-France team (Benjamin Siskoo & Frank Black) for help, remarks and advices
- Zydio for everything he has done ;)
- my translation team
- my beta-testers
- everyone supporting this project
- and of course Ben-J and Fabien again !

If you want to contact me (or the duck), write to :
saturnin@consollection.com

Before asking questions about the emulator, don't forget to read the FAQ, maybe your questions have already be answered !
Come and see us in the dedicated forums too :
http://www.forum.consollection.com/index.php?c=2

Don't forget the website !
http://saturnin.consollection.com

See you soon for some brand new adventures !

Runik


Saturnin 0.30 FAQ

FAQ

Q: It's the first time I use an emulator, and when I push start I have this "opcode inconnue" message !
A: Be sure that the bios are chosen (options->paths)

Q: I launched XXX, but I have the message "Operation of this cartridge is unavailable in this country" displayed on screen
A: Some games (like Funky Head Boxers, Find Love, Virtual Mahjong, etc...) need to be configured as 1 player game.
To do so, follow this procedure :
- Press F2 to pass the message
- Press F1 to enter the test menu
- In the menu, F1 is used to validate, and F2 to browse through the options
- Select "System Assignments"
- Change "2P" by "1P"
- Exit the menus 2 times, and the game will start

Q: I have weird things on screen / text parts are missing / colors seem wrong
A: Some cached textures might have been corrupted, reload them by pressing F9

Q: I pressed F9, and there are still problems on screen
A: Try to desactivate some VDP1 and VDP2 options in the debugger

Q: It still looks like shit !!!
A: Bad luck pal, you'll have to wait a newer release ;)

Q: Help ! I launched YYY, but start doesn't start the game !
A: This is a known problem, unfortunately there's no way to fix it right now ...

Q: I have a black vertical bar on the right side of the screen ... who ate the display ?
A: This problem can be fixed by checking "Force planes" in debug->VDP2

Q: Saturnin is reeeaaally slow on my PC, I don't understand because I have an Amintel XI 30 Ghz, a Zorglub 74800 and 48 GB of memory !
A: Almost nothing is optimized right now, I'm focusing on compatibility at first.

Q: Why I can't hear anything ? I washed my ears this morning !
A: There's no sound in Saturnin right now.

Q: Why there are huge files created by Saturnin ? I have almost no more space for my ... err .. pinguin pictures !
A: It's log files created by the debugger. They are overwritten everytime the emulator is started, and can be erased safely.